How to set up idlepc in gns3

203-Bad number of parameters (1 with min / max = 2/2)

I received a couple of messages from people who had trouble loading some of the labs I built in GNS3, this is the error they reported:

203-Bad number of parameters (1 with min / max = 2/2)

Fortunately, it's easy to fix if you doing what you are doing.

First you have to create a new project in GNS3, just click and drag a single router and boot it. Configure a hostname or a loopback or something and type write memory in the console. Now go to GNS3 and click on file other save project as, don’t forget to click on the save IOS startup configurations. Close GNS3 and open your topology .NET file in wordpad. it will look pretty much the same as my example:

autostart = False [127.0.0.1:7200] workingdir = C: \ DOCUME ~ 1 \ VMWare \ LOCALS ~ 1 \ Temp udp = 10000 [[3640]] image = C: \ Documents and Settings \ VMWare \ Desktop \ C3640-JK .BIN ghostios = True chassis = 3640 [[ROUTER R1]] model = 3640 console = 2003 cnfg = configs \ R1.cfg x = -100.0 y = -56.0 [GNS3-DATA] configs = configs

Now open up my topology file in wordpad, as an example I took the EIGRP beginner lab i created sometime ago. It's not the entire file just a part of it:

autostart = False [localhost: 7200] workingdir = / tmp udp = 10000 [[3640]] image = / Data / IOS Images / c3640-jk9s-mz.124-16.bin idlepc = 0x6059c528 ghostios = True chassis = 3640 [[ ROUTER R1]] model = 3640 console = 2001 slot0 = NM-1FE-TX f0 / 0 = R2 f0 / 0 slot1 = NM-1FE-TX f1 / 0 = R3 f0 / 0 x = -355.0 y = -225.0 [GNS3 -DATA] configs = EIGRP Beginner_configs m11 = 1.41421356237 m22 = 1.41421356237 [[NOTE 1]] text = Y x = -479.418397644 y = 7.79898987322 color = "# 1a1a1a"

Do you see the difference? The localhost might be different, it's probably 127.0.0.1 in your topology file. The workingdir is different for sure and so is the image location.

Let me compare them:

EIGRP beginners: [localhost: 7200] New Project: [127.0.0.1:7200] EIGRP beginners: workingdir = / tmp New Project: workingdir = C: \ DOCUME ~ 1 \ VMWare \ LOCALS ~ 1 \ Temp EIGRP Beginner: image = / Data / IOS Images / c3640-jk9s-mz.124-16.bin New Project: image = C: \ Documents and Settings \ VMWare \ Desktop \ C3640-JK.BIN

And you might have to check the configs directory structure. I'm also probably using another idlepc value so it's good to copy yours in the topology file.

So how to fix it? Easy! Just copy and paste your information in my topology file and save it. Open it in GNS3 and voila …… .a working lab!

If you want a real life example just watch this video I created:

If you have any questions or think this is useful please let me know by leaving a comment.

gns3